HOWTO: Galep5 programmer and FreeBSD


Poul-Henning Kamp
phk@FreeBSD.org
Revision $Id: Galep5.html,v 1.2 2011/06/01 13:32:50 phk Exp $

1.  Install Linux-o-lator compatibility packages
------------------------------------------------

At least these two are necessary:

        /usr/ports/graphics/linux-f10-dri
        /usr/ports/graphics/linux-f10-libGLU

More may be needed, but if so, my system already had them installed
due to other Linux-o-lator programs.


2.  Load Ethernet over USB device driver
----------------------------------------

Manually, when you want to use the programmer:

        kldload cdce

Automatically at boot:

        add 
                if_cdce_load="YES"
        to /boot/loader.conf


3.  Teach devd(8) a couple of tricks
------------------------------------

Create /etc/devd/galep5.conf, containing:

        notify 1000 {
                match "system"  "USB";
                match "vendor"  "0x1c12";
                match "product" "0x0001";
                action "/usr/sbin/usbconfig -d $ugen set_config 1";
        };

        attach 1000 {
                match "device-name" "^cdce[0-9]*";
                match "vendor"  "0x1c12";
                match "product" "0x0001";
                action "/sbin/ifconfig ue$interface 192.168.167.1";
        };


4.  Check connectivity
----------------------

Plug in the Galep5 and wait for the red LED to light.  This takes
around a minute or so.

Ping Galep5 to verify reachability:

        ping 192.168.167.12

Do not proceed until the Galep5 responds.

If this IP# is inconvenient for you, it is possible to change the
"167" part of that IPaddress using the supplied software (see below),
but not the other three bytes.  If you change it, you will obviously
have to change the /etc/devd/galep5.conf file accordingly.


5.  Install Galep5 software
---------------------------

As root:

        download  galepX-0.8.8.4.run til /tmp

        mkdir -p /opt/galepX
        chown $someuser /opt/galepX

As $someuser:

        cd /tmp
        sh galepX-0.8.8.4.run
        # The next two steps may not be necessary if whatever bug
        # prevents the script from finding run.sh is fixed in the future:
        cd data
        sh run.sh
        # Notice symlink to /usr/bin/galepX fails, ignore that.

6.  Run the Galep5 software
---------------------------

(kldload cdce if necessary, see step 2 above)

As $someuser:

        cd /opt/galepX
        ./galepX